Service Degradation
Incident Report for Cube Software
Resolved
The team is happy to report that all affected services are operating as expected. We appreciate your patience and understanding.
Posted Aug 08, 2024 - 15:42 EDT
Investigating
The team is investigating an issue that may impact some of our services. We understand the importance of our services to your operations and appreciate your patience as we work to identify the cause and implement a solution. We will provide updates as soon as we have more information.
Posted Aug 08, 2024 - 14:55 EDT
This incident affected: Imports and Calculations.