Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 03, 2024 - 09:00 EDT
Scheduled
Cube will be undergoing scheduled infrastructure maintenance - We do not expect significant service interruptions, but some customers may experience degraded performance and unresponsive actions during this window.
Posted Jul 29, 2024 - 09:28 EDT
This scheduled maintenance affected: Add-ons, Portal, Imports, Analytics, and Calculations.