Portal - Service Degradation
Incident Report for Cube Software
Resolved
The team has resolved the issue that was impacting our services, and will continue to monitor the application to ensure that everything continues working as expected.
Posted Jan 15, 2025 - 22:03 EST
Investigating
The team is investigating an issue that is impacting some of our services. We understand the importance of our services to your operations and appreciate your patience as we work to identify the cause and implement a solution. We will provide updates as soon as we have more information.
Posted Jan 15, 2025 - 21:55 EST
This incident affected: Portal and Imports.