Portal Issues
Incident Report for Cube Software
Resolved
The incident has been fully resolved, and the portal application is functioning as expected.
Posted Jul 13, 2023 - 15:25 EDT
Identified
Our team has identified an issue that is affecting our portal application. The root cause of the issue has been identified, and our team is working towards a resolution.
Posted Jul 13, 2023 - 15:15 EDT
This incident affected: Portal.