Google Sheets add-on Performance
Incident Report for Cube Software
Resolved
The Google Sheets performance issues experienced by some of our users have now been resolved.
Posted Apr 13, 2023 - 16:10 EDT
Monitoring
There is currently an issue affecting the performance of the Google Sheets APIs. Our engineers will continue to monitor the issue closely and provide an update as things progress.
Posted Apr 12, 2023 - 18:39 EDT
Investigating
We are investigating a potential performance issue with our Google Sheets add-on. We will provide more details as soon as more information is available.
Posted Apr 12, 2023 - 16:55 EDT
This incident affected: Add-ons.