Service Degradation - Background Tasks

Incident Report for Cube Software

Resolved

This incident has been resolved.
Posted May 08, 2026 - 13:50 EDT

Monitoring

Background Tasks are now operational.

We are continuing to monitor an ongoing AWS infrastructure event and will continue working to keep services healthy. Further updates will be provided as we continue monitoring.
Posted May 08, 2026 - 11:52 EDT

Identified

The team has identified the issue that has been impacting our Background Tasks. The team is now working to implement a solution. Further updates will be provided as we progress.
Posted May 08, 2026 - 10:33 EDT
This incident affected: Apps, Imports, and Calculations.