Google Sheets - Service Degradation
Incident Report for Cube Software
Resolved
The team is happy to report the issue impacting our customers using Chrome with our Google Sheets add-on has been resolved, and all affected services are now operating as expected. If you are still experiencing any issues, please try clearing your browser cache which should resolve the issue fully. We appreciate your patience and understanding.
Posted Nov 29, 2023 - 00:24 EST
Monitoring
Customers using Chrome with our Google Sheets add-on should see the issue resolved for them at this time. The team is still closely monitoring the application to ensure that everything is working as expected. We appreciate your understanding and patience during this time. We will continue monitoring the situation closely and provide another update soon.
Posted Nov 28, 2023 - 17:53 EST
Update
The team is still in the process of implementing a solution for our customers using Chrome with our Google Sheets add-on. We appreciate your understanding and patience during this time. We will continue to provide updates as we work towards a resolution.
Posted Nov 28, 2023 - 13:12 EST
Identified
The team has identified an issue impacting some customers using Chrome with our Google Sheets add-on. The team is now working to implement a solution. Further updates will be provided as we progress.
Posted Nov 28, 2023 - 11:54 EST
Investigating
The team is investigating an issue that is impacting our Google Sheets add-on. We understand the importance of our services to your operations and appreciate your patience as we work to identify the cause and implement a solution. We will provide updates as soon as we have more information.
Posted Nov 28, 2023 - 10:52 EST
This incident affected: Add-ons.