Add-ons & Portal Issues
Incident Report for Cube Software
Resolved
The incident has been fully resolved, and all systems are functioning normally.
Posted Jul 11, 2023 - 11:02 EDT
Identified
The root cause of the issue has been identified and our team is working towards a resolution. Thank you for your continued patience.
Posted Jul 11, 2023 - 11:00 EDT
Investigating
Our team is currently investigating an issue that is affecting both our add-ons and portal applications. We will provide updates once we have more information.
Posted Jul 11, 2023 - 10:54 EDT
This incident affected: Add-ons and Portal.